EXIBA SOMA DE TOTAIS POR TIPO EM UMA PLANILHA DE EXCEL


08 | MAI | 2013

APRENDA A EXIBIR O TOTAL DE REGISTROS QUE CONTENHAM UM DETERMINADO VALOR EXISTEM EM UMA LISTA

Todo mundo sabe somar valores numéricos em uma planilha de excel - ok, se você não sabe, basta colocar em uma célula =soma(A1:A10) e você verá a soma de todos os valores da coluna A da linha 1 à 10 - porém poucas pessoas sabem que também é possível exibir contagens baseadas em valores de texto.

Para exemplificar vamos utilizar a planilha de filmes previstos para 2013, que pode ser baixada clicando aqui.

A fórmula que vamos aprender hoje é a Contar Se:

=CONT.SE( ONDE ; O QUE)

ONDE representa onde o excel deve procurar, e O QUE representa o que ele deve procurar.

No caso nós vamos contar quantos filmes de ação existem nessa planilha, então nosso O QUE será a palavra "Ação", que precisa ficar entre aspas porque textos em fórmulas sempre precisam ficar entre aspas.

cont.se no excel

O gênero está na coluna B e começa na linha 7, como eu não sei quantas linhas essa planilha tem, mas sei que são menos de 1000, vou contar da linha 7 à linha 1000, então nosso ONDE se torna B7:B1000 :

=CONT.SE( B7:B1000; "Ação")

Simples assim, no caso essa célula mostrará que 24 filmes dessa lista são de ação. Mas espera lá... Estou vendo na lista que alguns filmes são colocados como Ação / Aventura... Como na informática tudo é exato, esse cálculo só contou as células onde está escrito simplesmente Ação.

Para contar os filmes que contenham ação, podemos usar o * que é o símbolo universal de "qualquer coisa". Ou seja, se ao invés de usarmos "Ação", usarmos "*Ação*" o Excel procurará qualquer campo que contenha a palavra Ação, indiferente de ter mais coisas escritas antes ou depois da palavra.

=CONT.SE( B7:B1000; "*Ação*")

Vale lembrar que podemos utilizar o * de outras formas, por exemplo, podemos colocá-lo apenas na frente da palavra - "*Ação" - fazendo isso contaremos as células que tiverem "Aventura / Ação" mas não contaremos células que por ventura tenham "Ação / Aventura".

Mas e se eu quiser saber quantos filmes não são de Ação? Aí devemos primeiro descobrir quantos filmes existem, para isso entra o código:

=CONT.SE( B7:B1000; "<>")

Esse código vai contar quantas células estão preenchidas (são diferentes de nada) entre a célula B7 e a B1000. No nosso caso são 170.

Para saber quantos filmes não são de ação, basta subtrair os filmes de ação do total de filmes:

=CONT.SE( B7:B1000; "<>")-CONT.SE( B7:B1000; "Ação")

Lembrando que quantos filmes não são de ação é diferente de quantos filmes não contém ação... O código acima ainda conta filmes como "Ação / Aventura". Para remover completamente a ação da contagem simplesmente coloque os asteriscos:

=CONT.SE( B7:B1000; "<>")-CONT.SE( B7:B1000; "*Ação*")

cont.se no excel

E pronto! Mais uma que você aprendeu para aprimorar seus conhecimentos no Excel.


       




REDES SOCIAIS

FACEBOOK
TWITTER